Script modifications needed for using the new version of AERIUS Connect

Wednesday, 28 September 2016
Logo AERIUS

The new version of AERIUS Connect will be released on 1 October. Users will have to modify existing scripts for the Connect API to continue using AERIUS Connect. This was discussed in detail during the Connect Café on 23 September.

More than fifteen representatives from various organizations and with a range of levels of experience were at Bij12 for the Connect Café. After the presentation about the implications of the changes, everyone was able to get down to work themselves. A lot of questions were answered with the help of the AERIUS team.

What has changed?

AERIUS Connect is a computer interface (API, Application Programming Interface) that has been built for performing complex calculations directly on AERIUS Calculator, instead of through the Calculator user interface. You therefore have to have the necessary programming skills in order to use AERIUS Connect. For technical reasons, the WebSocket protocol will be exchanged for the HTTP/REST protocol on 1 October. These protocol changes require modifications to certain scripts. In addition, the new Connect API uses a secure connection and an API key. This API key, which is an identification token linked to the user, replaces the e-mail address as identification for calculation tasks and status information.

What do you need to do to work with the new version of the Connect API?

The user has to modify certain scripts that load the Connect API. An example Python script for the Connect API 3.0 is available and can be downloaded from https://gitlab.com/AERIUS/aerius-connect-examples.
 
The software needed for working with the Connect API can be generated by your own software using Swagger (http://swagger.io).

The presentation attached provides further details of the modifications that are needed.


AERIUS Connect unavailable on 29 and 30 September

Because of the release of Connect API 3.0, AERIUS Connect is unavailable on 29 and 30 September. From 1 October onwards, AERIUS Connect can only be accessed using new scripts. You should therefore modify the scripts as soon as possible.

If you have any questions about the new Connect API 3.0, please speak to the AERIUS helpdesk.